posts
Get and Set Organisation links at Tenant and Site Level It has been a long awaited feature to set an expiry date on organisation sharing links
Get-PnPTenant | select-object CoreOrganizationSharingLinkMaxExpirationInDays, CoreOrganizationSharingLinkRecommendedExpirationInDays, RestrictResourceAccountAccess, EnforceRequestDigest, RestrictExternalSharingForAgents, AllowFileArchive, AllowFileArchiveOnNewSitesByDefault, EnableNotificationsSubscriptions
set-PnpTenant -RestrictExternalSharingForAgents $true -AllowFileArchive $true -AllowFileArchiveByDefault $true
WARNING: Failed to load 3 properties. Use -Verbose to see the details.
CoreOrganizationSharingLinkMaxExpirationInDays : 0 CoreOrganizationSharingLinkRecommendedExpirationInDays : 0 RestrictResourceAccountAccess : False EnforceRequestDigest : True RestrictExternalSharingForAgents : False AllowFileArchive : False AllowFileArchiveOnNewSitesByDefault : EnableNotificationsSubscriptions : False
posts
https://www.linkedin.com/posts/howdangrashid_microsoftai-powerplatform-copilotstudio-activity-7434145521402961920-JCuk?utm_source=share&utm_medium=member_desktop&rcm=ACoAAAPFiPoBIWB1aKfjibOBh_P3wQr2sdLHt8Q
https://developer.microsoft.com/en-us/reactor/events/26786/?wt.mc_id=meetup_26786_webpage_reactor
https://github.com/ankurkumarz/agentic-ai-knowledge-base
807b8f84-b788-4337-b773-b8e30349f392
https://res-foundry-0506.openai.azure.com/
JMC8Q~Qe2TVf~0.B6Lwgu9CGhRrppDoa-lwV0csa
Get-PnPTenant | select-object CoreOrganizationSharingLinkMaxExpirationInDays, CoreOrganizationSharingLinkRecommendedExpirationInDays, RestrictResourceAccountAccess, EnforceRequestDigest, RestrictExternalSharingForAgents, AllowFileArchive, AllowFileArchiveOnNewSitesByDefault, EnableNotificationsSubscriptions
set-PnpTenant -RestrictExternalSharingForAgents $true -AllowFileArchive $true -AllowFileArchiveByDefault $true
WARNING: Failed to load 3 properties. Use -Verbose to see the details.
CoreOrganizationSharingLinkMaxExpirationInDays : 0 CoreOrganizationSharingLinkRecommendedExpirationInDays : 0 RestrictResourceAccountAccess : False EnforceRequestDigest : True RestrictExternalSharingForAgents : False AllowFileArchive : False AllowFileArchiveOnNewSitesByDefault : EnableNotificationsSubscriptions : False
set-PnpTenant -CoreOrganizationSharingLinkRecommendedExpirationInDays 0 -CoreOrganizationSharingLinkMaxExpirationInDays 0 -RestrictResourceAccountAccess $false -RestrictExternalSharingForAgents $false -EnforceRequestDigest $true -AllowFileArchive $False -AllowFileArchiveOnNewSitesByDefault $false
posts
In case of throttling ot large volume of request processing, there might be time out issues, throttling issues, etc.. skipping the setting application
$clientId = "xxxxxx" #Read-Host "Please enter the Entra Id registration:" # Connection String Variables, including client specific ID and Tenant $TenantUrl = "https://contoso.sharepoint.com" $TenantName = "contoso" function Invoke-With-Retry { param ( [scriptblock]$Operation, [string]$ErrorMessage, [string]$SuccessMessage, [int]$MaxRetries = 5, [int]$RetryDelay = 5 ) $attempt = 0 while ($attempt -lt $MaxRetries) { try { & $Operation Log-Message $SuccessMessage "Success" return } catch { $attempt++ if ($attempt -ge $MaxRetries) { Log-Message "$ErrorMessage.